Server Maintenance
Incident Report for TaxBandits
Resolved
Our API services are back to normal
Posted Nov 23, 2018 - 07:54 UTC
Investigating
Our API services will be down due to Server Upgrade. We will be back in 20 mins.
Posted Nov 23, 2018 - 07:30 UTC
This incident affected: Webhooks and Forms API.