Partial Service Outage
Incident Report for TaxBandits
Resolved
Our API services are back to normal
Posted Feb 05, 2019 - 08:07 UTC
Investigating
We are currently experiencing a partial outage on all our services. We are investigating and will keep you posted.
Posted Feb 05, 2019 - 07:42 UTC
This incident affected: Forms API.